Páginas filhas
  • 02. Entenda os Pré-Requisitos
Ir para o final dos metadados
Ir para o início dos metadados

Para a utilização do TAF existem alguns pré-requisitos que devem ser analisados, conforme abaixo:

De ambiente:

  • Aplicar ultima LIB disponível no portal

Por escopo - quando o TAF estiver sendo integrado com produtos TOTVS:

Dependendo do escopo (Fiscal, eSocial e/ou ECF), o backoffice também deve sofrer atualizações quanto as rotinas envolvidas na integração, àquelas que criam a mensagem de comunicação com o TAF.  

Clique para saber mais 


Particularidades:

    • Nas integrações com ERPs NÃO TOTVS, é preciso que o ERP desenvolva a mensagem de integração com o TAF
    • Para clientes que utilizarem o TAF na versão 12 ou superior é premissa que o servidor de licença esteja na Nuvem( Santo Graal ).
    • No caso do TAF ter um database particular, separado do ERP; força o dbAccess a utilizar 2 conexões simultâneas com o SGBD, consumindo 2 licenças. No mesmo database, uma conexão já basta.
    • Por se tratar de um novo produto, comporta somente banco de dados relacional homologados pela TOTVS;
    • Específica do eSocial/EFD Reinf: Estas 2 obrigações fiscais possuem um formato particular de transmissão eletrônica para o Governo, necessitando do serviço de mensageira da TOTVS (TSS); e a versão compatível com estas obrigações é o TSS na versão 12 (3.0). Este produto nesta versão é instalado automaticamente através do instalador do TAF, ou caso já esteja disponível no ambiente onde o TAF está sendo inserido, deve-se promover a atualização do mesmo para a versão comentada, pois é a única versão que comporta o eSocial e EFD Reinf.